It is currently Tue Nov 21, 2017 1:09 am

Hvac gone nut's, 96 Sebring XJI

View active topics

All times are UTC - 5 hours


Post new topic Reply to topic  [ 1 post ] 
Author Message
 PostPosted: Sat Sep 30, 2017 10:51 am   
Copper Member

Joined: Fri Sep 29, 2017 8:54 pm
Posts: 4
With your comment's here i was able to fugure out the HVAC problem with a 96 Sebring XJI vert.
It all started with a ac check.
I pulled the cap's of the service ports and found a schrader valve leaking. I recovered the R-134A Freon and replaced the valve.
While charging the system i found the ac compressor wouldn't engage. But it would engage in defrost mode.
So until i could trouble shoot this more. i decided to finish the recharge in defrost mode.

In the mean time my Wife noticed that the rear window defroster light was coming on and off and a clicking noise in the dash, Also the mode control on the havc was randomly going nut's, as in not deciding which position it wanted to be in. And then depressing the AC control was inop.

After reading all the related topic's i seen that the hvac control unit was the main culprit and the mode door motor was 2nd. So i swapped out the hvac control assy and it's now working.

Thank you all who put in there 2 cent's in all the post's and thank's to Bret from Des Moines for the many call's we had.

C-ya Scott


Top
 Profile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Style originally created by Volize © 2003 • Redesigned SkyLine by MartectX © 2008 - 2010